GermanLook Forums  

Go Back   GermanLook Forums > General > Project Builds

Reply
 
Thread Tools Display Modes
  #46  
Old September 26th 2015, 12:57
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
My Son bought me a new key ring for the Ghia -- Does he know something I don't????

Reply With Quote
  #47  
Old October 11th 2015, 05:05
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Got to talk and hang out with Finnegan and Freiburger for about a hour today at the Optima Challenge --

They were working on a yellow Mazda rotary pickup with a 455 front engine Olds mounted in the bed -- they bought it from a guy who claimed it was a 10 sec car -- must of been timed in the 100 foot, cause it was a dog LOL

I didn't have much to offer them as far as help or suggestions, BUT they had some very nice eye candy hanging around them and it made walking away very VERY difficult LMAO

Did get a cool sticker -- Had volunteered to help doing the Tech-in early this am (before it got into the 100's) and the guy making the stickers messed up as it was suppose to be intermediate, so I took the damn thing LOL -- don't know if it should go on the Ghia or the tool box -- probably be the tool box

Reply With Quote
  #48  
Old October 22nd 2015, 23:30
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
SO -- -- About December 15th I had the engine out and got the trans back from Benco -- I reinstalled the engine did some upgrades, and started putting everything back together

Immediately, I started having EFI problems -- turn on master power -- Electromotive EFI would come on run all the prestart stuff, hit start, engine would run for 20-30 seconds and shut off -- -- -- I would turn off the 'key', turn on the 'key' -- nothing -- kill the master power everything would repeat, engine would run, shut off, again everything dead

Holy crap I was vexed,,,,, so I sent the box back to Electromotive,, came back,, still the same thing,,, sent the box back and they sent me a new one as a replacement...... By this time I was pissed and I had the AEM setting on the shelf, so I started the AEM install -- -- So flash forward until this month and I had finally finished the install (OK, OK , I know I'm slow, but I was just frustrated with everything) I took the Ghia over the WesTech in Mira Loma to double check everything I had done on the install of the AEM and for them to tune the damn thing......

So I get a call from Eric @ WesTech last Friday, the Damn AEM is doing the same freaking thing, turn on main power, turn the 'key' on -- it would cycle thru everything perfectly, turn the 'key' off, turn 'key' back on -- -- box is all pissed off -- turn main power off/on -- start over, it work once then fail.....

WTF is going on???????????

I am Stumped -- I had gone through the wiring twice during the install checking everything -- -- I really dwelling on this thinking, thinking............ I'm thinking that the ARC switches is letting a small of current to flow through when the 'key' is off, not letting the memory clear for a clean restart...... Nah!! how can that happen through the relays......

SOOOO, I'm in bed Saturday night at about 11:30, almost asleep, when it hits me, The freaking alternator has a bad diode in it and letting current bleed through -- -- Hmmmm just might be it...

Monday night after work, I swing by WesTech, walk over to the Ghia, pull the exciter wire off the alternator.... SHAZAMMMM, freaking problem disappears -- -- 10 DAM months working on this thing and it was just a bad freaking Alternator from the very beginning...... who would of thunk it.......................................
Reply With Quote
  #49  
Old October 25th 2015, 17:07
Steve C's Avatar
Steve C Steve C is offline
Registered User
 
Join Date: Sep 2002
Location: Sydney, Australia
Posts: 1,666
Long process but now its fixed, if we wanted a simple life we wouldn't play around with these old cars, keeps your mind active and young, well that's what I tell myself
__________________
STI powered 1303 in the works.
Reply With Quote
  #50  
Old October 28th 2015, 21:00
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
https://www.youtube.com/watch?v=Vzv40VWL5ho
Reply With Quote
  #51  
Old October 29th 2015, 10:33
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Wellll, The guys at WesTech are really MAD at me - --- -- - One of the front oil coolers decided to split open while the car was on the dyno Monday -- what a mess -- Freaking car was still dripping oil out of the spare tire drain Tuesday when I went over to help by-pass that cooler -- should of just put another oil cooler in its place, but their description of what happen had me confused -- -- but I've been working nights lately so I'm in a constant state of confusion LOL (still had to have the blue towels and rags there to continue to mop up the oil in this picture LOL)

Don't know when they will have some open dyno time so they can get the Ghia back on there



They did have a cool open class desert car on the dyno Tuesday -- -- about a half million dollar toy there



Reply With Quote
  #52  
Old October 30th 2015, 19:52
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Was over working on the oil cooler at WesTech -- Chad from BangShift was there -- He had a junkyard SBC on the Dyno and all the guys there were running around the dyno and giggling and laughing and just cracking up -- --- --

They had setup two targets behind the headers and were pouring BB's down the carb and watching them hit the targets.... It was the craziest thing I'd ever watched-- I don't know which was funnier watching the BB's come shooting out of the headers or the guys running around laughing their azzes off -- -- Then they pulled the plugs out after their "run" OMG .. .. well, look at the pictures.....

Soon to be a video to be posted somewhere :::::::::::::::::::::::



If you look closely you can see all the BB's on the floor....

Reply With Quote
  #53  
Old November 5th 2015, 12:41
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
A little update -- -- Nothing is happening LMAO

The last 2 weeks the guys from WesTech have been jammed with the high dollar cars going to SEMA (or Chad destroying a SBC) or Eric being sicker than a dog -- Hope he's feeling better !!! -- Went over to work on the Ghia this morning, but they've all left to go to SEMA too..... Oh well, it's not like I've anywhere to go LOL -- and remember I'm the one who made the deal that the Ghia is not their first priority, just something for them work on when they can -- so really no problem as far as I'm concerned, because they are treating the ghia very well !!!

SO, Screw it,,,, I'm going on Vacation -- see you all in a couple of weeks
Reply With Quote
  #54  
Old December 8th 2015, 11:27
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
This was in my in-box today -- --

Circuit of The Americas (COTA) February 26-28, 2016



Good Morning:

I hope this finds each of you in good spirits as we trek through Fall toward Winter. I for one think a more southern location is in the cards. HMMM, perhaps Austin, Texas?!

For the fourth year in a row, it’s time to think about three days of driving on America’s only purpose built F1 track, Circuit of The Americas (COTA) in Austin, Texas. MVP Track Time has scheduled our 4th annual three-day COTA track event for February 26 – 28, 2016.

Now for the moment you’ve all been waiting for, the investment to play at COTA. The entry fee for all three days is $1,375, the same as 2014. As with previous years, there are a limited number of spots available for COTA. Yes, they fill fast.

STEP 1
The $1,375 entry fee for all three days at COTA can only be completed with Pay Pal (you can use any major credit card through the Pay Pal system if you don’t have a Pay Pal account) at the link below:

https://www.paypal.com/cgi-bin/websc...=JQ3XJ9LSZHJUN


STEP 2
Once you have completed the entry fee, head over to the “Registration Page” of MVP’s web site (link below) to register. You’ll need to scroll to the bottom of the page to complete the blue outlined registration box. Click on the“Event” drop-down menu and choose Circuit of The Americas (COTA): February 26-28, 2016.

http://www.mvptracktime.com/id92.html


After we have allocated the registrations by run group, based on individual track experience, we will send out group confirmation e-mails to each run group. We will have four (blue, green, yellow and red) run groups allowing us to schedule two hours of track time daily.

In the spirit of transparency, the rental of COTA, as you can guess, is rather costly, so once you register, MVP will not be able to give you a refund until COTA is sold out and we have a replacement for you. If/when we can replace you, there will be a $100 cancellation fee. Inside of four weeks (January 29, 2016 and later) prior to the COTA event there is no refund. This is the reality of renting Circuit of The Americas.

If you have any questions, grab the phone and call me at (314) 249-3770 or you can e-mail Feffman@MVPTrackTime.com.

Happy Motoring and I hope to see you at COTA. Enjoy your day.

Mark Pfeffer – MVP Track Time
www.MVPTrackTime.com
Phone: (314) 249-3770
E-mail: Feffman@MVPTrackTime.com
Reply With Quote
  #55  
Old January 22nd 2016, 01:32
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Been working hard on the tune on the Ghia


Here's the latest dyno sheet::::


Reply With Quote
  #56  
Old April 29th 2016, 11:04
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
https://www.youtube.com/watch?v=D4WAUmyKDq0
Reply With Quote
  #57  
Old May 20th 2016, 14:02
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
It's Story telling day and it's Baseball season (here in the states) and the final year of Vin Skully's 67 year career announcing Baseball -- -- Here are a few of the stories he interweaves into his broadcasts that makes him so great.......

http://m.mlb.com/cutfour/2016/04/27/...ll-a-story-day
Reply With Quote
  #58  
Old May 24th 2016, 19:36
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Reply With Quote
  #59  
Old May 25th 2016, 11:43
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Well, The Ghia is back home -- -- It has been gone so much the past year that there almost wasn't a space for it in the garage..... you know how a empty spot in the garage fills up quick LOL



I brought the damn thing home Sunday, with more problems than it left with, oil leaks up the arse and just a ton of electrical issues. It runs OK. It drives on and off the trailer and goes down the road, then it just shuts off -- -- guess I'm just gonna reach in there and grab a handful of wiring and just rip it out and start over.... Ordered some new electrical things and they will be here tomorrow night, so tomorrow I'll get started straightening out my rats nest and decide how I want to proceed.....

On the way home, I was cruising a car show at the Riverside Auto Center with the Ghia on the trailer, and there was Ester (E-girl)((Powder puff VW racer par excellence)). I didn't know she was Ms. Route 66.... Damn she looked good in that tiara... LOL
Reply With Quote
  #60  
Old May 31st 2016, 10:11
Fiatdude Fiatdude is offline
Registered User
 
Join Date: Feb 2015
Posts: 119
Monday, thinking I had the electrical all sorted out, I took the car out on my little 3 mile test loop I use. Left one signal and was rolling onto the throttle, trying to get my gremlins to reappear. Damn, only boosting to 4-5 pounds, double damn, forgot to plug-in the boost controller and was only running on the waste gate spring..... Turned onto a side street so I could connect it back together... As I climbed out, this new GT Mustang pulls up next to me and rolls down his window... "I usually don't stop and congratulate someone for beating me, but that little thing is fast ! Whatcha got in it??"

"Just a stocker with a little boost," I replied, "If I'd known we were racing, I would of really got after it!!!!" Hope I don't go to hell for all the little lies I tell, LMAO.

He drove away shaking his head..... Don't mess with the Air Cooled!!!!! LOL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 00:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
© www.GermanLook.net 2002-2017. All Rights Reserved